FIT Radio Workout Music - Playback issues
Incident Report for
Sonos
Resolved
This incident has been resolved.
Posted
Mar
25
,
2026
-
17:02
UTC
Identified
We've identified a problem with FIT Radio Workout Music on Sonos and are working with them on a fix. You may be unable to start playing music from FIT Radio Workout Music until it’s resolved.
Posted
Mar
24
,
2026
-
20:06
UTC
This incident affected: FIT Radio Workout Music.
×
Subscribe to Incident
Subscribe to updates for
FIT Radio Workout Music - Playback issues
via . You'll receive .